Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PERSONAL SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 IamKangy 23-04-2020 04:34:56

When I manually go to the cron job link for the email digest I get this message:

An error has occurred. For more details please view "logs/errors.log".

[23 April 2020 @ 14:26PM] Email Digest Completed - Started: 23 Apr 2020/14:26PM, Finished: 23 Apr 2020/14:26PM -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Within the log file I get this:

[Error Code: 2] strtotime(): Invalid date.timezone value 'Host', we selected the timezone 'UTC' for now.
[Date/Time: 23 April 2020 @ 04:24AM]
[Error on line 140 in file /home/hws2020/domains/hydrawebservices.com/public_html/helpdesk/control/system/core/sys-controller.php]

My cron job is:

/usr/bin/php/home/hws2020/public_html/helpdesk/control/cron/email-digest.php

I am not really sure what is wrong or why it is not working. Any help would be grateful.

#2 msworld 23-04-2020 13:47:34

This is a server setting. The "date.timezone" configuration is in your PHP.ini file, so check the value there. Looks like it has an invalid timezone?

#3 IamKangy 24-04-2020 05:45:48

Time zone in the php.ini is fine. There is no issue there. The person that manages my VPS says everything is fine server side it is something to do with your coding. I never had this problem on the previous version.

#4 msworld 24-04-2020 06:46:58
IamKangy wrote:

Time zone in the php.ini is fine. There is no issue there. The person that manages my VPS says everything is fine server side it is something to do with your coding. I never had this problem on the previous version.

Can you email me your licence.lic file? Seems the value 'Host' is coming from that.
support@maianscriptworld.co.uk

#5 IamKangy 24-04-2020 08:49:59

Yeah sure I will do that now.

#6 IamKangy 24-04-2020 08:50:26

Yeah sure I will do that now.

#7 msworld 24-04-2020 10:02:00

Thanks, will be in touch again asap.

Board footer

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2020 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software