Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PERSONAL SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 KingfisherTech 17-08-2020 06:14:17

I am evaluating Maian Lockbox for our new app.  It's PHP-based and will have several membership types and access to specific documents.  If we go with Lockbox, we'll be getting the White Label license.

I am having trouble with the install, however.  I was getting the mysql error:

Error: Variable 'sql_mode' can't be set to the value of 'NO_AUTO_CREATE_USER'

from

/var/www/html/maian/control/classes/class.db.php

Line: 459:

SET `sql_mode` = 'IGNORE_SPACE,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION'

I thought I had strict mode turned off in our RDS instance.  It kept giving me this error on install.  So, in an effort to debug, I tried to just remove the offending Constant, replacing the line with this line:

SET `sql_mode` = 'IGNORE_SPACE,NO_ENGINE_SUBSTITUTION'

Which allowed me to complete the install!  However, I added in the demo data and I cannot seem to login as an admin, despite using the username and password I defined in

admin/control/access.php

Server values
Ubuntu 18.04
PHP 7.3
Amazon RDS running MySQL 8.0.17

I can't imagine that no one has tried to use this with AWS yet -- can you point me in the right direction?


Thanks in advance!


Scott Kallen
KingfisherFiles

Last edited by KingfisherTech (17-08-2020 06:18:16)

#2 msworld 19-08-2020 02:45:43

Hi Scott,

Does the login appear to work, but the page just reloads back to the login page? Sounds like a session issue?

I don't know anything about Amazon RDS or AWS, I don't use them.

Board footer

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2020 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software