Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 jjjjeczalik 02-11-2018 19:42:32

A few days ago (without making any changes to anything), modal windows stopped loading. (Attempting to add an MP3 or a collection to the cart results in the display of the animated loading.gif but nothing else. The error in the log noted that

[Error Code: 8] Trying to get property of non-object
[redacted]
[Error on line 400 in file /[redacted]/control/classes/class.cart.php]


After a couple of days of rolling back edits, eventually all the way back to the original script, I reinstalled the entire script from scratch, using a brand new database as well, and once if was successfully installed, I noticed two things : The admin login does not work no matter what, and bypassing it (by using nothing at all as the username and password) gets me into the admin area, where any action that would ordinarily result in a modal window that says "updated successfully" instead triggers the following in the MM error.log :

Error Code: 8] Undefined index: autoenable
[Date/Time: 2 November 2018 @ 19:11PM]
[Error on line 248 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 262 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 263 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 264 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 273 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: curdisplay
[Error on line 305 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: curdisplay
[Error on line 305 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: website
[Error on line 310 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: email
[Error on line 311 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: httppath
[Error on line 312 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -

[and eight more that are similar to these, followed by]

- - - - - - - - - - - - - - - - - - -
[Error Code: 2] Cannot modify header information - headers already sent by (output started at /home3/e1jizrc7/yfhamilton.com/music-store/control/classes/class.errors.php:129)
[Error on line 9 in file /............................../control/classes/class.json.php]
- - - - - - - - - - - - - - - - - - -

[All of the errors have the same date, so I deleted most of those for the sake of brevity.]

For something to just change like that suggests that something changed on my end, but the situation developed overnight, and now the problem is such that Maian Music doesn't work properly upon re-installation. Meaning that it is certainly not a bug, but if you have heard of this sort of problem happening before, then you probably have a simple way out of it smile

#2 msworld 06-11-2018 06:22:53

It looks like your settings table got affected? Those errors you mentioned are missing columns in the settings table.

Not sure what could have caused it. sad

Board footer

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2018 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software