Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 mlcarey 25-06-2018 21:36:10

Error Code: 1067.  Invalid default value for 'sendate'  when creating mr_broadcast table


I am using MySql Server version 5.7.21

explicit_defaults_for_timestamp=true

; Set the SQL mode to strict
;sql-mode=""
;sql-mode="STRICT_ALL_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_DATE,NO_ZERO_IN_DATE,NO_AUTO_CREATE_USER"

#2 msworld 25-06-2018 22:26:16

MySQL running in strict mode isn`t supported, sorry.

#3 mlcarey 26-06-2018 17:23:09

David

These are the settings from the MySQL  my.ini file. 

The sql_mode value is not set.  To set the value you must remove the semi colon.

I read setting the explicit_defaults_for_timestamp=true will fix this error, but it didn't. 

I had to change the default date values to '1970-01-01 00:00:01' and it installed.

#4 mlcarey 26-06-2018 18:46:58

David


After uncommenting the sql_mode = " " directive in the MySQL my.ini file, the database installed. 

Marcus

#5 msworld 27-06-2018 21:13:17

Hi Marcus,

Great, glad you got it working.

Board footer

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2018 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software