Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 ctstech 24-03-2018 19:35:43

Hello I ran into this error on a clean ubuntu 16.04 install managed by ServerPilot

Software: Maian Support
Script Version: 4.0
PHP Version: 7.2.3
DB Version: 5.7.21-0ubuntu0.16.04.1-log
Server Software: Apache/2.4.28 (Unix) OpenSSL/1.0.2g
Platform: Other
=================================================================================
Table: msp_settings
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'autoenable'
On Line: 666
In File: ....install/control/tables.php
- - - - - - - - - - - - - - - - - - - - -

I found a previous message with this (and other errors) perhaps something to do with mysql and strict mode?

Get installation error. Server is a new dedicated running Ubuntu 16.04 and Apache2 with php 7 MySQL 5 and all the requirements
Script: Maian Lockbox
Script Version: 2.1
PHP Version: 7.0.8-0ubuntu0.16.04.2
DB Version: 5.7.13-0ubuntu0.16.04.2
Server Software: Apache/2.4.18 (Ubuntu)
Platform: Windows
=================================================================================
Table: ml_boxes
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'autoenable'
On Line: 64
In File: /var/www/html/install/control/tables.php
- - - - - - - - - - - - - - - - - - - - -

Never mind I figured it out. There are a few results that say there are up to five files to edit to turn off strict mode in ubuntu mysql. But I found on google a way to make one new file that does it.
Create the file /etc/mysql/conf.d/disable_strict_mode.cnf
Then add this to it and save.
[mysqld]
sql_mode=IGNORE_SPACE,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

Any suggestions to troubleshoot?

Last edited by ctstech (24-03-2018 19:38:07)

#2 msworld 25-03-2018 13:27:11

Yes, it`s mysql running in strict mode. To fix, redownload Maian Support and replace:

control/lib/db.php

#3 ctstech 25-03-2018 21:31:28

Thank you David.

Ok, downloaded the script from your site today (6pm Chile time)

the db.php file has a size of 7803 and a date of march 25 09:22

I deleted the original db.php in the /control/lib directory
copied the new db.php
I deleted the log in /logs/
reset ownership etc
Filled out the details on the install/ page and all was ok but I still get the error logs/install-error-report.txt

which is

Software: Maian Support
Script Version: 4.0
PHP Version: 7.0.28
DB Version: 5.7.21-0ubuntu0.16.04.1-log
Server Software: Apache/2.4.28 (Unix) OpenSSL/1.0.2g
Platform: Other
=================================================================================
Table: msp_settings
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'autoenable'
On Line: 666
In File:..../install/control/tables.php

As mentioned, I also stepped it down to v 7.0 just to be sure

Last edited by ctstech (25-03-2018 21:35:59)

#4 msworld 26-03-2018 02:47:41

It`s a mysql issue, not php. Anyway, my fault, sorry, forgot to remove the 'STRICT_TRANS_TABLES' directive.

Can you try it again please?
https://www.maiansupport.com/download.html

#5 ctstech 26-03-2018 11:42:45
msworld wrote::

Can you try it again please?

Perfect! and yes, so far no problems with php 7.2.
Thank you

#6 msworld 26-03-2018 14:09:04

Superb smile

Board footer

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2018 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software