Support Forums


If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 hamada 29-12-2017 15:23:13

Hello there,

When trying to do a db backup from the admin cp, the following error is generated in the log file. I am using the app on Plesk Onyx VPS with MariaDB 10.x

Alternatively, I can do a backup directly from phpMyAdmin or Plesk, but thought to report this anyways to see if there is a solution.

[Error Code: 2] mysqli_fetch_object() expects parameter 1 to be mysqli_result, boolean given
[Date/Time: 28 December 2017 @ 11:26AM]
[Error on line 39 in file /var/www/vhosts/xxxxxx.com/help.xxxxxx.com/admin/templates/system/settings/backup.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 2] mysqli_fetch_object() expects parameter 1 to be mysqli_result, boolean given
[Date/Time: 29 December 2017 @ 10:19AM]
[Error on line 39 in file /var/www/vhosts/xxxxxx.com/help.xxxxxx.com/hqadmin/templates/system/settings/backup.php]
- - - - - - - - - - - - - - - - - - -

Last edited by hamada (29-12-2017 15:38:21)

#2 msworld 29-12-2017 16:05:46

Can I ask what your database name is?

#3 hamada 29-12-2017 16:20:00

XXXXXXX-SUPPORT

Last edited by hamada (29-12-2017 17:08:20)

#4 msworld 29-12-2017 16:36:15

Yep, thought so. This is an issue with database names with hyphens which MySQL doesn`t like.

Fixed in 3.7. If you rename the database and use an underscore it should be fine.

#5 hamada 29-12-2017 17:08:51
msworld wrote::

Yep, thought so. This is an issue with database names with hyphens which MySQL doesn`t like.

Fixed in 3.7. If you rename the database and use an underscore it should be fine.

Awesome. Thank you!

#6 msworld 30-12-2017 04:04:04

You are welcome. smile

Board footer