Support Forums


If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 Kavatch 22-11-2017 19:52:36

So when I get a Email from the System It looks like this:

thunderbird_2017-11-22_20-48-08.png


So it is not showing the template text but when I look at the src of the mail it shows the text in it:


thunderbird_2017-11-22_20-51-34.png


How can I fix this error?

Last edited by Kavatch (22-11-2017 19:53:09)

#2 msworld 23-11-2017 08:55:23

No idea. sad I haven`t seen this issue before.

Have you tried it in other email clients?

#3 Kavatch 23-11-2017 17:21:19
msworld wrote::

No idea. sad I haven`t seen this issue before.

Have you tried it in other email clients?

Yes I have opend it on my Phone in Thunderbird and in a web Client.
//Edit: It looks like the Template has not been added to the mail.
thunderbird_2017-11-23_19-22-58.png

Last edited by Kavatch (23-11-2017 18:24:03)

#4 Kavatch 23-11-2017 21:47:04

More Edits: I debugged the code a bit and It looks like the error is comming from this methode: " htmlWrap() "

2 Edit: I debugged the code with:

error_log( "-----" );
error_log($mail);

to test if the html was right and the out put was: "-----" So the $mail variable used here:

$this->MsgHTML($this->htmlWrap($mail));

sesms to be null.

3 Edit: Nevermind. I testet it again with:

      error_log( "1-----" );
      error_log($this->htmlWrap($mail));
      error_log( "2-----" );
      error_log($this->plainWrap($mail));

and this time it was the right output.

4 Edit: After some more testing it looks like the methode :

$this->convertChar($MSPARSER->mswAutoLinkParser($cont));

is the thing that is responsible for this.

5 Edit: Yep I removed the methode

$this->convertChar($MSPARSER->mswAutoLinkParser($cont));

to test it and it worked.

6 Edit: Could it be because the domains ends with a ".eu" and the methode only uses this?:

$ext  = 'com|org|net|gov|edu|mil|co.uk|uk.com|us|info|biz|ws|name|mobi|cc|tv';

7 Edit: I didnt get it to work when I just added a "|eu" to the "$ext" var so I had to edit the mail templates so the umlauts workd and also add a <a></a> to the links.
______________
If I find more out I will edit this post.

Last edited by Kavatch (23-11-2017 22:46:19)

#5 msworld 26-11-2017 15:27:09

Ok thanks. I`ve not had anyone else report mail issues.

Could it be because the domains ends with a ".eu" and the methode only uses this?

I don`t think that should make any difference.

Board footer