Support Forums


If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PRIORITY SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 mattmartinolc 04-09-2016 17:42:17

Get installation error. Server is a new dedicated running Ubuntu 16.04 and Apache2 with php 7 MySQL 5 and all the requirements curl/json/etc

Script: Maian Lockbox
Script Version: 2.1
PHP Version: 7.0.8-0ubuntu0.16.04.2
DB Version: 5.7.13-0ubuntu0.16.04.2
Server Software: Apache/2.4.18 (Ubuntu)
Platform: Windows
=================================================================================
Table: ml_boxes
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'autoenable'
On Line: 64
In File: /var/www/html/install/control/tables.php
- - - - - - - - - - - - - - - - - - - - -
Table: ml_members
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'joined'
On Line: 156
In File: /var/www/html/install/control/tables.php
- - - - - - - - - - - - - - - - - - - - -
Table: ml_settings
Operation: Create
Error Code: 1067
Error Msg: Invalid default value for 'signenable'
On Line: 272
In File: /var/www/html/install/control/tables.php
- - - - - - - - - - - - - - - - - - - - -

#2 mattmartinolc 04-09-2016 23:31:19

Ended up doing the install manually using the .sql file in the schema folder and now can log in. But As before just like the last server I tried to do this one, the admin settings do not save. The graphic just keeps on and never saves the settings. I really want this to work.

[Error Code: 8] Undefined offset: 4
[Date/Time: 5 September 2016 @ 00:27AM]
[Error on line 415 in file /var/www/html/control/classes/class.db.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined offset: 4
[Date/Time: 5 September 2016 @ 00:28AM]
[Error on line 415 in file /var/www/html/control/classes/class.db.php]
- - - - - - - - - - - - - - - - - - -

#3 msworld 05-09-2016 01:52:45

Sadly, Maian Lockbox doesn`t currently support MySQL running in strict mode, which is the problem.

#4 mattmartinolc 05-09-2016 02:41:51

Well I can configure it anyway that's needed. How to do what you suggest?

Last edited by mattmartinolc (05-09-2016 02:42:29)

#5 mattmartinolc 05-09-2016 03:53:03

Nevermind I figured it out. There are a few results that say there are up to five files to edit to turn off strict mode in ubuntu mysql. But I found on google a way to make one new file that does it.

Create the file /etc/mysql/conf.d/disable_strict_mode.cnf

Then add this to it and save.

[mysqld]
sql_mode=IGNORE_SPACE,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

Then restart the mysql service. Done. Works now - can't wait to finally play with it.

#6 msworld 06-09-2016 16:18:23

Superb, glad you got it sorted. smile

Board footer