Community Forum

If you have questions about my software, chances are this forum has the answers.

You'll need to register before you can post on the forum to ask your question or to answer another one. A reply will be posted to each and every question that is asked so there is no need to double post or bump your post. I do my best to answer promptly but in some cases it may take a day or two. If you bump your post, it may be removed. Bear with me and I`ll get your question answered quickly.

Here are a few tips to help you to get your questions answered more rapidly.

IMPORTANT: Posts in English only. I don't have a translator and I'll be unable to understand your message properly and will probably delete it.
SEARCH: Use the search option to see if your question has been answered on the forum before now or if there is an answer in the documentation of your software.
PERSONAL SUPPORT: If you have purchased a commercial version of any software, using the contact option at the licence centre ensures a faster response.
AUTO DELETION: Accounts older than 5 days, with no posts or topics, are automatically deleted. Only register if you are thinking of posting.
LINKS: Any links posted are not clickable and must be copied / pasted into your browser address bar.

You are not logged in.

#1 ceeohtwo 07-03-2021 14:45:35

That code actually works. I just needed to clear my cache. I'm looking into running Apache and Nginx on the same server.

Thanks again.

msworld wrote:

No problem, glad you are making progress. I do use Nginx, but not if I need to use rewrite rules. I think there is a way of running Apache and Nginx together?

#2 ceeohtwo 06-03-2021 01:34:57

I'm new around here so apologies for posting in both places and thanks for the .htaccess rewrite code. I was able to convert it to nginx using the following in my configuration file:

location ~ .*\.(ico|gif|jpg|jpeg|png|js|css) {
}

location / {
  if (!-e $request_filename){
    rewrite ^/([^?]*) /index.php?_msw_=$1;
  }
}

However, one or two of the resulting search engine friendly urls downloads when you visit them instead of displaying the .php page. It's progress but I need to figure out the logic better.

Thanks again.

#3 ceeohtwo 04-03-2021 18:38:45

Hi there.

I'm setting up the script on my Debian 10 Nginx server and the option for search engin friendly urls in admin cp/options does not work on my NGINX server. Can someone share what code I need to put in my configuration file to correct this problem?

The default setting has urls with strings like https://domain-name.com/?e=8 which shows an individual cards. However,  when I change to Search Engine Friendly Urls at Admin CP/options/ and change the Search Engine Friendly Urls to yes I get an error 404 at the new URL at https://domain-name.com/ecard/enjoy-your-honeymoon

Thanks.

Board footer

 

Maian Script World - Free PHP Software for Personal or Business Use.
© 2003-2021 Maian Script World & David Ian Bennett.

2Checkout.com is an authorized reseller of goods and services provided by Maian Script World

Free PHP Software / Responsive PHP Scripts / Lightweight PHP Software / White Label PHP Software