Problem after hosting migration

Hi,
I have changed hosting providers and everything went smoothly (almost).
My databases transferred flawlessly, so did the shop script, howvever:
My admin bit works fine, but when I try to access the main shop part (the user bit) I get: "[System Message] You have enabled search engine friendly urls. Please rename the 'htaccess_COPY.txt' file to '.htaccess' and reload page".

I have done as the message tells me, but I keep getting the message.
What else can I do to solve this, please?

Thank you.