Sudden misbehavior, modal windows no longer display

A few days ago (without making any changes to anything), modal windows stopped loading. (Attempting to add an MP3 or a collection to the cart results in the display of the animated loading.gif but nothing else. The error in the log noted that

[Error Code: 8] Trying to get property of non-object
[redacted]
[Error on line 400 in file /[redacted]/control/classes/class.cart.php]


After a couple of days of rolling back edits, eventually all the way back to the original script, I reinstalled the entire script from scratch, using a brand new database as well, and once if was successfully installed, I noticed two things : The admin login does not work no matter what, and bypassing it (by using nothing at all as the username and password) gets me into the admin area, where any action that would ordinarily result in a modal window that says "updated successfully" instead triggers the following in the MM error.log :

Error Code: 8] Undefined index: autoenable
[Date/Time: 2 November 2018 @ 19:11PM]
[Error on line 248 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 262 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 263 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 264 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: access
[Error on line 273 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: curdisplay
[Error on line 305 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: curdisplay
[Error on line 305 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: website
[Error on line 310 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: email
[Error on line 311 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -
[Error Code: 8] Undefined index: httppath
[Error on line 312 in file /............................../control/classes/class.settings.php]
- - - - - - - - - - - - - - - - - - -

[and eight more that are similar to these, followed by]

- - - - - - - - - - - - - - - - - - -
[Error Code: 2] Cannot modify header information - headers already sent by (output started at /home3/e1jizrc7/yfhamilton.com/music-store/control/classes/class.errors.php:129)
[Error on line 9 in file /............................../control/classes/class.json.php]
- - - - - - - - - - - - - - - - - - -

[All of the errors have the same date, so I deleted most of those for the sake of brevity.]

For something to just change like that suggests that something changed on my end, but the situation developed overnight, and now the problem is such that Maian Music doesn't work properly upon re-installation. Meaning that it is certainly not a bug, but if you have heard of this sort of problem happening before, then you probably have a simple way out of it smile